.gitignore: ignore local vscode workspace settings file
[lttng-tools.git] / tests / regression / ust / clock-override / Makefile.am
index 2a226303aa7d36c4455ce4ad5c9477dcf0b4b911..ff6c6a2924ca2ad744e064c03dc13049dc099dd3 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 if NO_SHARED
 # Do not build this test if shared libraries support was
 # explicitly disabled.
@@ -9,27 +11,19 @@ EXTRA_DIST = test_clock_override lttng-ust-clock-override-test.c
 
 else
 
-AM_CPPFLAGS = -I$(srcdir) -I$(top_srcdir)/src
-
 # The rpath is necessary because libtool won't build a shared library
 # if it's noinst_
 GETCPU_LIBTOOL_FLAGS = \
     -module \
     -shared \
     -avoid-version \
-    --no-as-needed \
+    -Wl,--no-as-needed \
     -rpath $(abs_builddir)
 
 noinst_LTLIBRARIES = lttng-ust-clock-override-test.la
 lttng_ust_clock_override_test_la_LDFLAGS = $(GETCPU_LIBTOOL_FLAGS)
 lttng_ust_clock_override_test_la_SOURCES = lttng-ust-clock-override-test.c
-
-if LTTNG_TOOLS_BUILD_WITH_LIBDL
-lttng_ust_clock_override_test_la_LIBADD = -ldl
-endif
-if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
-lttng_ust_clock_override_test_la_LIBADD = -lc
-endif
+lttng_ust_clock_override_test_la_LIBADD = $(DL_LIBS)
 
 noinst_SCRIPTS = test_clock_override
 EXTRA_DIST = test_clock_override
This page took 0.023414 seconds and 4 git commands to generate.