Clean-up: modernize pretty_xml.cpp
[lttng-tools.git] / tests / regression / ust / Makefile.am
index 9fcbda6d93f9d83febe861ca92d8bd10a2025c55..dd8186f9a652953aa62fbf88a25a1b4ca56583cf 100644 (file)
@@ -1,10 +1,42 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 if HAVE_LIBLTTNG_UST_CTL
-SUBDIRS = nprocesses high-throughput low-throughput before-after multi-session \
-               overlap buffers-pid linking daemon exit-fast fork libc-wrapper \
-               periodical-metadata-flush java-jul java-log4j python-logging \
-               getcpu-override clock-override baddr-statedump ust-dl
+SUBDIRS = \
+       before-after \
+       blocking \
+       buffers-pid \
+       clock-override \
+       daemon \
+       exit-fast \
+       fork \
+       getcpu-override \
+       high-throughput \
+       java-jul \
+       java-log4j \
+       java-log4j2 \
+       libc-wrapper \
+       linking \
+       low-throughput \
+       multi-lib \
+       multi-session \
+       namespaces \
+       nprocesses \
+       overlap \
+       periodical-metadata-flush \
+       rotation-destroy-flush \
+       type-declarations \
+       ust-constructor
+
+if HAVE_OBJCOPY
+SUBDIRS += \
+       baddr-statedump \
+       ust-dl
+endif
 
-EXTRA_DIST = test_event_basic test_event_tracef test_event_perf
+EXTRA_DIST = \
+       test_event_basic \
+       test_event_perf \
+       test_event_tracef
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.025526 seconds and 4 git commands to generate.