fix: relayd: unaligned access in trace_chunk_registry_ht_key_hash
[lttng-tools.git] / tests / regression / ust / Makefile.am
index 2dd6fe9b4fd0b01d3b0f0c932533cdaa17fbf720..dd8186f9a652953aa62fbf88a25a1b4ca56583cf 100644 (file)
@@ -1,7 +1,55 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 if HAVE_LIBLTTNG_UST_CTL
-SUBDIRS = nprocesses high-throughput low-throughput before-after multi-session \
-               overlap buffers-uid linking daemon
+SUBDIRS = \
+       before-after \
+       blocking \
+       buffers-pid \
+       clock-override \
+       daemon \
+       exit-fast \
+       fork \
+       getcpu-override \
+       high-throughput \
+       java-jul \
+       java-log4j \
+       java-log4j2 \
+       libc-wrapper \
+       linking \
+       low-throughput \
+       multi-lib \
+       multi-session \
+       namespaces \
+       nprocesses \
+       overlap \
+       periodical-metadata-flush \
+       rotation-destroy-flush \
+       type-declarations \
+       ust-constructor
+
+if HAVE_OBJCOPY
+SUBDIRS += \
+       baddr-statedump \
+       ust-dl
+endif
+
+EXTRA_DIST = \
+       test_event_basic \
+       test_event_perf \
+       test_event_tracef
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
 
-EXTRA_DIST = test_event_basic test_event_wildcard
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
 
 endif
This page took 0.024752 seconds and 4 git commands to generate.