.gitignore: ignore local vscode workspace settings file
[lttng-tools.git] / tests / regression / tools / trigger / utils / Makefile.am
index 21fb531122521e3e2ff079a14c8479eda017138b..d90a45ea570e2b82e31eddfe1292d3539bd3c230 100644 (file)
@@ -1,17 +1,18 @@
 # SPDX-License-Identifier: GPL-2.0-only
 
-AM_CFLAGS += -I$(srcdir) -I$(top_srcdir)/tests/utils
+AM_CPPFLAGS += -I$(srcdir) -I$(top_srcdir)/tests/utils
 LIBLTTNG_CTL=$(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la
+LIBCOMMON_LGPL=$(top_builddir)/src/common/libcommon-lgpl.la
 
 noinst_PROGRAMS = \
        notification-client \
        register-some-triggers
 
-notification_client_SOURCES = notification-client.c
-notification_client_LDADD = $(LIBLTTNG_CTL) \
+notification_client_SOURCES = notification-client.cpp
+notification_client_LDADD = $(LIBLTTNG_CTL) $(LIBCOMMON_LGPL) \
        $(top_builddir)/tests/utils/libtestutils.la
 
-register_some_triggers_SOURCES = register-some-triggers.c
+register_some_triggers_SOURCES = register-some-triggers.cpp
 register_some_triggers_LDADD = $(LIBLTTNG_CTL) \
-       $(top_builddir)/src/common/filter/libfilter.la \
-       $(top_builddir)/src/common/bytecode/libbytecode.la
+       $(top_builddir)/src/common/libfilter.la \
+       $(top_builddir)/src/common/libbytecode.la
This page took 0.023756 seconds and 4 git commands to generate.