Fix: support VPATH build for tests
[lttng-tools.git] / tests / regression / tools / health / Makefile.am
index 94e54dfaf0655d6cba9cb21ba7c87c6eef494e98..c22d5ee390ab1592583dfe1a93987300a21d81af 100644 (file)
@@ -36,3 +36,20 @@ health_check_SOURCES = health_check.c $(UTILS)
 health_check_LDADD = $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la \
                     $(top_builddir)/src/common/libcommon.la
 endif
+
+dist_noinst_SCRIPTS = test_thread_exit test_thread_stall test_tp_fail
+EXTRA_DIST = test_thread_exit test_thread_stall test_tp_fail
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.025084 seconds and 4 git commands to generate.