Build fix: Apps defining _LGPL_SOURCE must link to urcu-bp
[lttng-tools.git] / tests / regression / tools / filtering / Makefile.am
index ca60dbf632d7c90466d8000597231d0e7047e09e..b4f8d76f0c40770a8447be45e8fddc663958851e 100644 (file)
@@ -11,8 +11,22 @@ endif
 if HAVE_LIBLTTNG_UST_CTL
 noinst_PROGRAMS = gen-ust-events
 gen_ust_events_SOURCES = gen-ust-events.c tp.c tp.h
-gen_ust_events_LDADD = -llttng-ust
+gen_ust_events_LDADD = -llttng-ust -lurcu-bp
 endif
 
 noinst_SCRIPTS = test_unsupported_op test_invalid_filter test_valid_filter
 EXTRA_DIST = test_unsupported_op test_invalid_filter test_valid_filter
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.023269 seconds and 4 git commands to generate.