Fix: Don't override user variables within the build system
[lttng-tools.git] / tests / regression / tools / filtering / Makefile.am
index ca60dbf632d7c90466d8000597231d0e7047e09e..712edefb63c7cec039a475e9882071c1ea13a7bc 100644 (file)
@@ -1,18 +1,31 @@
-AM_CFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src -I$(top_srcdir)/tests -I$(srcdir) -O2 -g
-AM_LDFLAGS =
+AM_CPPFLAGS += -I$(top_srcdir)/tests -I$(srcdir)
 
 if LTTNG_TOOLS_BUILD_WITH_LIBDL
-AM_LDFLAGS += -ldl
+LIBS += -ldl
 endif
 if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
-AM_LDFLAGS += -lc
+LIBS += -lc
 endif
 
 if HAVE_LIBLTTNG_UST_CTL
 noinst_PROGRAMS = gen-ust-events
 gen_ust_events_SOURCES = gen-ust-events.c tp.c tp.h
-gen_ust_events_LDADD = -llttng-ust
+gen_ust_events_LDADD = -llttng-ust -lurcu-bp
 endif
 
 noinst_SCRIPTS = test_unsupported_op test_invalid_filter test_valid_filter
 EXTRA_DIST = test_unsupported_op test_invalid_filter test_valid_filter
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.023448 seconds and 4 git commands to generate.