Fix: lttng-snapshot: use after free of max size argument
[lttng-tools.git] / tests / regression / tools / filtering / Makefile.am
index b214fc1d69c0be70d554547bccafb3ab70ee0edb..4a851c32ff17ef8c61316619ca62979c37000f5e 100644 (file)
@@ -1,9 +1,18 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 AM_CPPFLAGS += -I$(top_srcdir)/tests -I$(srcdir)
 
 if HAVE_LIBLTTNG_UST_CTL
+# Disable some warnings flags to accomodate the tracepoint headers
+WARN_FLAGS = \
+       -Wno-redundant-decls
+
+AM_CFLAGS += $(WARN_FLAGS)
+AM_CXXFLAGS += $(WARN_FLAGS)
+
 noinst_PROGRAMS = gen-ust-events
 gen_ust_events_SOURCES = gen-ust-events.c tp.c tp.h
-gen_ust_events_LDADD = -llttng-ust -lurcu-bp $(DL_LIBS)
+gen_ust_events_LDADD = $(UST_LIBS) $(DL_LIBS)
 endif
 
 noinst_SCRIPTS = test_unsupported_op test_invalid_filter test_valid_filter
This page took 0.030485 seconds and 4 git commands to generate.