fix: relayd: unaligned access in trace_chunk_registry_ht_key_hash
[lttng-tools.git] / tests / regression / kernel / Makefile.am
index f06f51528fb75b093238caeacb6589d9af34e7b9..4fef90d36b18766553458b8211f4e1316750b65d 100644 (file)
@@ -1,13 +1,15 @@
 # SPDX-License-Identifier: GPL-2.0-only
 
-EXTRA_DIST = test_all_events test_syscall \
+
+EXTRA_DIST = test_all_events \
                                                 test_callstack \
+                                                test_channel \
                                                 test_clock_override \
                                                 test_event_basic \
                                                 test_kernel_function \
                                                 test_lttng_logger \
                                                 test_ns_contexts \
-                                                test_ns_contexts_change
+                                                test_ns_contexts_change \
                                                 test_rotation_destroy_flush \
                                                 test_select_poll_epoll \
                                                 test_syscall \
@@ -15,9 +17,11 @@ EXTRA_DIST = test_all_events test_syscall \
                                                 validate_select_poll_epoll.py
 
 noinst_PROGRAMS = select_poll_epoll
-select_poll_epoll_SOURCES = select_poll_epoll.c
-select_poll_epoll_LDADD = $(POPT_LIBS)
-select_poll_epoll_CFLAGS = $(POPT_CFLAGS) -fno-stack-protector -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=0 $(AM_CFLAGS)
+select_poll_epoll_SOURCES = select_poll_epoll.cpp
+select_poll_epoll_LDADD = $(POPT_LIBS) $(top_builddir)/src/common/libcommon-lgpl.la
+select_poll_epoll_CPPFLAGS = $(POPT_CFLAGS) $(AM_CPPFLAGS)
+# Disable stack protection, the test overflows the stack to test the poll/epoll syscalls
+select_poll_epoll_CXXFLAGS = -fno-stack-protector $(AM_CXXFLAGS)
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.02409 seconds and 4 git commands to generate.