Clean-up: modernize pretty_xml.cpp
[lttng-tools.git] / tests / regression / kernel / Makefile.am
index ca73ed43ef6326ef663c423d0ba89409a9481c94..4fef90d36b18766553458b8211f4e1316750b65d 100644 (file)
@@ -1,4 +1,27 @@
-EXTRA_DIST = test_event_basic test_all_events test_syscall test_clock_override
+# SPDX-License-Identifier: GPL-2.0-only
+
+
+EXTRA_DIST = test_all_events \
+                                                test_callstack \
+                                                test_channel \
+                                                test_clock_override \
+                                                test_event_basic \
+                                                test_kernel_function \
+                                                test_lttng_logger \
+                                                test_ns_contexts \
+                                                test_ns_contexts_change \
+                                                test_rotation_destroy_flush \
+                                                test_select_poll_epoll \
+                                                test_syscall \
+                                                test_userspace_probe \
+                                                validate_select_poll_epoll.py
+
+noinst_PROGRAMS = select_poll_epoll
+select_poll_epoll_SOURCES = select_poll_epoll.cpp
+select_poll_epoll_LDADD = $(POPT_LIBS) $(top_builddir)/src/common/libcommon-lgpl.la
+select_poll_epoll_CPPFLAGS = $(POPT_CFLAGS) $(AM_CPPFLAGS)
+# Disable stack protection, the test overflows the stack to test the poll/epoll syscalls
+select_poll_epoll_CXXFLAGS = -fno-stack-protector $(AM_CXXFLAGS)
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.023282 seconds and 4 git commands to generate.