Clean-up: modernize pretty_xml.cpp
[lttng-tools.git] / tests / regression / kernel / Makefile.am
index a257eb07a778c805b790ea9b2ccafb202a62d4b2..4fef90d36b18766553458b8211f4e1316750b65d 100644 (file)
@@ -19,7 +19,9 @@ EXTRA_DIST = test_all_events \
 noinst_PROGRAMS = select_poll_epoll
 select_poll_epoll_SOURCES = select_poll_epoll.cpp
 select_poll_epoll_LDADD = $(POPT_LIBS) $(top_builddir)/src/common/libcommon-lgpl.la
-select_poll_epoll_CFLAGS = $(POPT_CFLAGS) -fno-stack-protector -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=0 $(AM_CFLAGS)
+select_poll_epoll_CPPFLAGS = $(POPT_CFLAGS) $(AM_CPPFLAGS)
+# Disable stack protection, the test overflows the stack to test the poll/epoll syscalls
+select_poll_epoll_CXXFLAGS = -fno-stack-protector $(AM_CXXFLAGS)
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.022862 seconds and 4 git commands to generate.