Clean-up: modernize pretty_xml.cpp
[lttng-tools.git] / tests / regression / kernel / Makefile.am
index 040b76423a207e45494cd75107d4280b392aab3a..4fef90d36b18766553458b8211f4e1316750b65d 100644 (file)
@@ -9,7 +9,7 @@ EXTRA_DIST = test_all_events \
                                                 test_kernel_function \
                                                 test_lttng_logger \
                                                 test_ns_contexts \
-                                                test_ns_contexts_change
+                                                test_ns_contexts_change \
                                                 test_rotation_destroy_flush \
                                                 test_select_poll_epoll \
                                                 test_syscall \
@@ -17,9 +17,11 @@ EXTRA_DIST = test_all_events \
                                                 validate_select_poll_epoll.py
 
 noinst_PROGRAMS = select_poll_epoll
-select_poll_epoll_SOURCES = select_poll_epoll.c
-select_poll_epoll_LDADD = $(POPT_LIBS)
-select_poll_epoll_CFLAGS = $(POPT_CFLAGS) -fno-stack-protector -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=0 $(AM_CFLAGS)
+select_poll_epoll_SOURCES = select_poll_epoll.cpp
+select_poll_epoll_LDADD = $(POPT_LIBS) $(top_builddir)/src/common/libcommon-lgpl.la
+select_poll_epoll_CPPFLAGS = $(POPT_CFLAGS) $(AM_CPPFLAGS)
+# Disable stack protection, the test overflows the stack to test the poll/epoll syscalls
+select_poll_epoll_CXXFLAGS = -fno-stack-protector $(AM_CXXFLAGS)
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.023306 seconds and 4 git commands to generate.