tests: trigger action firing policy
[lttng-tools.git] / tests / regression / Makefile.am
index cc645fd740c512cd58493f992eb5be31464d6439..c66f64d887801fa7d9e49e5ff6d1189fc4555d4e 100644 (file)
@@ -6,7 +6,8 @@ LOG_DRIVER_FLAGS = --merge --post-script $(top_srcdir)/tests/utils/warn_processe
 LOG_DRIVER = env PGREP='$(PGREP)' AM_TAP_AWK='$(AWK)' $(SHELL) \
        $(top_srcdir)/config/tap-driver.sh
 
-TESTS = tools/filtering/test_invalid_filter \
+TESTS = tools/base-path/test_ust \
+       tools/filtering/test_invalid_filter \
        tools/filtering/test_unsupported_op \
        tools/filtering/test_valid_filter \
        tools/streaming/test_ust \
@@ -29,11 +30,15 @@ TESTS = tools/filtering/test_invalid_filter \
        tools/regen-statedump/test_ust \
        tools/notification/test_notification_ust_error \
        tools/notification/test_notification_ust_buffer_usage \
+       tools/notification/test_notification_ust_capture \
        tools/notification/test_notification_ust_event_rule_condition_exclusion \
        tools/notification/test_notification_kernel_error \
        tools/notification/test_notification_kernel_buffer_usage \
+       tools/notification/test_notification_kernel_capture \
        tools/notification/test_notification_kernel_instrumentation \
        tools/notification/test_notification_kernel_syscall \
+       tools/notification/test_notification_notifier_discarded_count \
+       tools/notification/test_notification_kernel_userspace_probe \
        tools/notification/test_notification_multi_app \
        tools/rotation/test_ust \
        tools/rotation/test_kernel \
@@ -41,10 +46,10 @@ TESTS = tools/filtering/test_invalid_filter \
        tools/rotation/test_schedule_api \
        tools/metadata/test_kernel \
        tools/working-directory/test_relayd_working_directory \
-       tools/notification/test_notification_multi_app \
        tools/clear/test_ust \
        tools/clear/test_kernel \
        tools/tracker/test_event_tracker \
+       tools/trigger/start-stop/test_start_stop \
        tools/trigger/test_add_trigger_cli \
        tools/trigger/test_list_triggers_cli \
        tools/trigger/test_remove_trigger_cli
@@ -68,7 +73,8 @@ TESTS += ust/before-after/test_before_after \
        ust/multi-lib/test_multi_lib \
        ust/rotation-destroy-flush/test_rotation_destroy_flush \
        tools/metadata/test_ust \
-       tools/relayd-grouping/test_ust
+       tools/relayd-grouping/test_ust \
+       tools/trigger/firing-policy/test_ust_firing_policy
 
 if IS_LINUX
 TESTS += \
This page took 0.024456 seconds and 4 git commands to generate.