Add Log4j 2.x agent tests for the 'log4j' domain
[lttng-tools.git] / tests / regression / Makefile.am
index 1d24a79663bf6d89d47b9a876fd77a3a5e82b3c9..7ac7e0974106f4a79417ed1d527660a37a9de549 100644 (file)
@@ -1,10 +1,14 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 SUBDIRS = tools kernel ust
 
 LOG_DRIVER_FLAGS = --merge --post-script $(top_srcdir)/tests/utils/warn_processes.sh
 LOG_DRIVER = env PGREP='$(PGREP)' AM_TAP_AWK='$(AWK)' $(SHELL) \
-       $(top_srcdir)/config/tap-driver.sh
+       $(top_srcdir)/tests/utils/tap-driver.sh
 
-TESTS = tools/filtering/test_invalid_filter \
+TESTS = tools/base-path/test_ust \
+       tools/channel/test_channel \
+       tools/filtering/test_invalid_filter \
        tools/filtering/test_unsupported_op \
        tools/filtering/test_valid_filter \
        tools/streaming/test_ust \
@@ -25,8 +29,17 @@ TESTS = tools/filtering/test_invalid_filter \
        tools/crash/test_crash \
        tools/regen-metadata/test_ust \
        tools/regen-statedump/test_ust \
-       tools/notification/test_notification_ust \
-       tools/notification/test_notification_kernel \
+       tools/notification/test_notification_ust_error \
+       tools/notification/test_notification_ust_buffer_usage \
+       tools/notification/test_notification_ust_capture \
+       tools/notification/test_notification_ust_event_rule_condition_exclusion \
+       tools/notification/test_notification_kernel_error \
+       tools/notification/test_notification_kernel_buffer_usage \
+       tools/notification/test_notification_kernel_capture \
+       tools/notification/test_notification_kernel_instrumentation \
+       tools/notification/test_notification_kernel_syscall \
+       tools/notification/test_notification_notifier_discarded_count \
+       tools/notification/test_notification_kernel_userspace_probe \
        tools/notification/test_notification_multi_app \
        tools/rotation/test_ust \
        tools/rotation/test_kernel \
@@ -34,10 +47,15 @@ TESTS = tools/filtering/test_invalid_filter \
        tools/rotation/test_schedule_api \
        tools/metadata/test_kernel \
        tools/working-directory/test_relayd_working_directory \
-       tools/notification/test_notification_multi_app \
        tools/clear/test_ust \
        tools/clear/test_kernel \
-       tools/tracker/test_event_tracker
+       tools/tracker/test_event_tracker \
+       tools/trigger/start-stop/test_start_stop \
+       tools/trigger/test_add_trigger_cli \
+       tools/trigger/test_list_triggers_cli \
+       tools/trigger/test_remove_trigger_cli \
+       tools/trigger/name/test_trigger_name_backwards_compat \
+       tools/trigger/hidden/test_hidden_trigger
 
 if HAVE_LIBLTTNG_UST_CTL
 SUBDIRS += ust
@@ -46,8 +64,6 @@ TESTS += ust/before-after/test_before_after \
        ust/multi-session/test_multi_session \
        ust/nprocesses/test_nprocesses \
        ust/overlap/test_overlap \
-       ust/java-jul/test_java_jul \
-       ust/java-log4j/test_java_log4j \
        ust/python-logging/test_python_logging \
        ust/getcpu-override/test_getcpu_override \
        ust/clock-override/test_clock_override \
@@ -57,10 +73,40 @@ TESTS += ust/before-after/test_before_after \
        ust/blocking/test_blocking \
        ust/multi-lib/test_multi_lib \
        ust/rotation-destroy-flush/test_rotation_destroy_flush \
-       ust/namespaces/test_ns_contexts \
-       ust/namespaces/test_ns_contexts_change \
        tools/metadata/test_ust \
-       tools/relayd-grouping/test_ust
+       tools/relayd-grouping/test_ust \
+       tools/trigger/rate-policy/test_ust_rate_policy
+
+if TEST_JAVA_JUL_AGENT
+TESTS += ust/java-jul/test_java_jul
+endif # TEST_JAVA_JUL_AGENT
+
+if TEST_JAVA_LOG4J_AGENT
+TESTS += ust/java-log4j/test_java_log4j
+endif # TEST_JAVA_LOG4J_AGENT
+
+if TEST_JAVA_LOG4J2_AGENT
+TESTS += ust/java-log4j2/test_agent_log4j2_domain_log4j
+endif # TEST_JAVA_LOG4J2_AGENT
+
+if IS_LINUX
+TESTS += \
+       kernel/test_all_events \
+       kernel/test_callstack \
+       kernel/test_channel \
+       kernel/test_clock_override \
+       kernel/test_event_basic \
+       kernel/test_kernel_function \
+       kernel/test_lttng_logger \
+       kernel/test_ns_contexts \
+       kernel/test_ns_contexts_change \
+       kernel/test_rotation_destroy_flush \
+       kernel/test_select_poll_epoll \
+       kernel/test_syscall \
+       kernel/test_userspace_probe \
+       ust/namespaces/test_ns_contexts \
+       ust/namespaces/test_ns_contexts_change
+endif # IS_LINUX
 endif # HAVE_LIBLTTNG_UST_CTL
 
 if PYTHON_BINDING
This page took 0.024081 seconds and 4 git commands to generate.