fix: relayd: unaligned access in trace_chunk_registry_ht_key_hash
[lttng-tools.git] / tests / Makefile.am
index 9d4e0dc0d809fd00ea99085fcc565549a7c40c37..01babf7da37b00702baff59ecac0d65a2d95c194 100644 (file)
@@ -1,18 +1,22 @@
-SUBDIRS = utils regression unit stress
+# SPDX-License-Identifier: GPL-2.0-only
 
-if USE_PYTHON
+SUBDIRS =
+
+if BUILD_TESTS
+SUBDIRS += . utils meta unit regression stress destructive perf
+if HAVE_PGREP
 check-am:
-       ./run.sh unit_tests
-       ./run.sh fast_regression
-       ./run.sh with_bindings_regression
+       $(top_srcdir)/tests/utils/warn_processes.sh $(PGREP)
+endif
 else
-check-am:
-       ./run.sh unit_tests
-       ./run.sh fast_regression
+       @echo "========================================="
+       @echo "WARNING: Tests were disabled at configure"
+       @echo "========================================="
 endif
 
-dist_noinst_SCRIPTS = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression
-EXTRA_DIST = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression
+
+dist_noinst_SCRIPTS = run.sh long_regression root_regression
+EXTRA_DIST = run.sh long_regression root_regression README
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.023892 seconds and 4 git commands to generate.