Tests: Replace prove by autotools tap runner
[lttng-tools.git] / tests / Makefile.am
index 2f1f1c38b36d1727b7dcbd291a41e6c5a67df719..58caeb1590fde8fdd33feb4e658b4f1f182d1bc5 100644 (file)
@@ -1,21 +1,21 @@
-SUBDIRS = utils regression unit stress
-
-installcheck-am:
-       ./run.sh unit_tests
-       ./run.sh fast_regression
-if USE_PYTHON
-       ./run.sh with_bindings_regression
-endif
+SUBDIRS =
+DIST_SUBDIRS = utils regression unit stress destructive
 
+if BUILD_TESTS
+SUBDIRS += . utils regression unit stress destructive
+if HAS_PGREP
 check-am:
-       ./run.sh unit_tests
-       ./run.sh fast_regression
-if USE_PYTHON
-       ./run.sh with_bindings_regression
+       $(top_srcdir)/tests/utils/warn_lttng_processes.sh $(PGREP)
 endif
+else
+       @echo "========================================="
+       @echo "WARNING: Tests were disabled at configure"
+       @echo "========================================="
+endif
+
 
-dist_noinst_SCRIPTS = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression
-EXTRA_DIST = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression README
+dist_noinst_SCRIPTS = run.sh fast_regression long_regression root_regression root_destructive_tests
+EXTRA_DIST = run.sh fast_regression long_regression root_regression README root_destructive_tests
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.023072 seconds and 4 git commands to generate.