Fix: wait for the completion of implicit session rotations
[lttng-tools.git] / src / lib / lttng-ctl / Makefile.am
index 2178ed32f4728c61aedd98a131da6f73fdd9a12f..32d0aff54f3c04123caf170ec31b158eaa063df8 100644 (file)
@@ -1,10 +1,15 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src -I$(builddir)
-
 SUBDIRS = filter
 
+AM_CPPFLAGS += -I$(srcdir) -I$(builddir)
+
 lib_LTLIBRARIES = liblttng-ctl.la
 
-liblttng_ctl_la_SOURCES = lttng-ctl.c snapshot.c
+liblttng_ctl_la_SOURCES = lttng-ctl.c snapshot.c lttng-ctl-helper.h \
+               lttng-ctl-health.c save.c load.c deprecated-symbols.c \
+               channel.c rotate.c event.c destruction-handle.c
+
+liblttng_ctl_la_LDFLAGS = \
+               $(LT_NO_UNDEFINED)
 
 liblttng_ctl_la_LIBADD = \
                $(top_builddir)/src/common/sessiond-comm/libsessiond-comm.la \
This page took 0.024539 seconds and 4 git commands to generate.