lttng-ctl: add event expression API
[lttng-tools.git] / src / lib / lttng-ctl / Makefile.am
index 32d0aff54f3c04123caf170ec31b158eaa063df8..28aead7ad6cbb72cd7d4f9275cc594d029eece5f 100644 (file)
@@ -1,4 +1,6 @@
-SUBDIRS = filter
+# SPDX-License-Identifier: GPL-2.0-only
+
+SUBDIRS =
 
 AM_CPPFLAGS += -I$(srcdir) -I$(builddir)
 
@@ -6,16 +8,16 @@ lib_LTLIBRARIES = liblttng-ctl.la
 
 liblttng_ctl_la_SOURCES = lttng-ctl.c snapshot.c lttng-ctl-helper.h \
                lttng-ctl-health.c save.c load.c deprecated-symbols.c \
-               channel.c rotate.c event.c destruction-handle.c
+               channel.c rotate.c event.c destruction-handle.c clear.c \
+               event-expr.c \
+               tracker.c
 
 liblttng_ctl_la_LDFLAGS = \
                $(LT_NO_UNDEFINED)
 
 liblttng_ctl_la_LIBADD = \
                $(top_builddir)/src/common/sessiond-comm/libsessiond-comm.la \
-               $(top_builddir)/src/common/libcommon.la \
-               $(top_builddir)/src/common/hashtable/libhashtable.la \
-               $(top_builddir)/src/lib/lttng-ctl/filter/libfilter.la
+               $(top_builddir)/src/common/libcommon.la
 
 pkgconfigdir = $(libdir)/pkgconfig
 pkgconfig_DATA = lttng-ctl.pc
This page took 0.024055 seconds and 4 git commands to generate.