Fix: Don't override user variables within the build system
[lttng-tools.git] / src / lib / lttng-ctl / Makefile.am
index d87eb85486c978995fbf925a20e58604149511c3..03c073c9d74261dc5d363e8a562737cc8c82d04f 100644 (file)
@@ -1,10 +1,15 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src -I$(builddir)
-
 SUBDIRS = filter
 
+AM_CPPFLAGS += -I$(srcdir) -I$(builddir)
+
 lib_LTLIBRARIES = liblttng-ctl.la
 
-liblttng_ctl_la_SOURCES = lttng-ctl.c snapshot.c lttng-ctl-helper.h
+liblttng_ctl_la_SOURCES = lttng-ctl.c snapshot.c lttng-ctl-helper.h \
+               lttng-ctl-health.c save.c load.c deprecated-symbols.c \
+               channel.c
+
+liblttng_ctl_la_LDFLAGS = \
+               $(LT_NO_UNDEFINED)
 
 liblttng_ctl_la_LIBADD = \
                $(top_builddir)/src/common/sessiond-comm/libsessiond-comm.la \
This page took 0.023321 seconds and 4 git commands to generate.