Fix: Don't override user variables within the build system
[lttng-tools.git] / src / lib / lttng-ctl / Makefile.am
index 5b87e38b7b155896fb8b9738d52355a2af7d31e4..03c073c9d74261dc5d363e8a562737cc8c82d04f 100644 (file)
@@ -1,11 +1,15 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src -I$(builddir)
-
 SUBDIRS = filter
 
+AM_CPPFLAGS += -I$(srcdir) -I$(builddir)
+
 lib_LTLIBRARIES = liblttng-ctl.la
 
 liblttng_ctl_la_SOURCES = lttng-ctl.c snapshot.c lttng-ctl-helper.h \
-               lttng-ctl-health.c save.c load.c deprecated-symbols.c
+               lttng-ctl-health.c save.c load.c deprecated-symbols.c \
+               channel.c
+
+liblttng_ctl_la_LDFLAGS = \
+               $(LT_NO_UNDEFINED)
 
 liblttng_ctl_la_LIBADD = \
                $(top_builddir)/src/common/sessiond-comm/libsessiond-comm.la \
This page took 0.023234 seconds and 4 git commands to generate.