Remove extern "C" from internal headers
[lttng-tools.git] / src / common / consumer / Makefile.am
index c628312892c1b6adf44632659493f712f53a97a9..ba3ecf1da3834879d9053d409cfee063d57e53d2 100644 (file)
@@ -1,11 +1,19 @@
-# Consumer library
+# SPDX-License-Identifier: GPL-2.0-only
+
 noinst_LTLIBRARIES = libconsumer.la
 
 noinst_HEADERS = consumer-metadata-cache.h consumer-timer.h \
                 consumer-testpoint.h
 
-libconsumer_la_SOURCES = consumer.c consumer.h consumer-metadata-cache.c \
-                         consumer-timer.c consumer-stream.c consumer-stream.h
+libconsumer_la_SOURCES = \
+       consumer.cpp \
+       consumer.h \
+       consumer-metadata-cache.cpp \
+       consumer-stream.cpp \
+       consumer-stream.h \
+       consumer-timer.cpp \
+       metadata-bucket.cpp \
+       metadata-bucket.h
 
 libconsumer_la_LIBADD = \
                $(top_builddir)/src/common/sessiond-comm/libsessiond-comm.la \
This page took 0.023173 seconds and 4 git commands to generate.