Introduce libcommon-lgpl for liblttng-ctl
[lttng-tools.git] / src / common / consumer / Makefile.am
index 296301e6f360fa122dad866cb7943f5773c6f8fe..46810d116c51ca5ccb431ba1bbb23c898c4bfb4e 100644 (file)
@@ -5,14 +5,19 @@ noinst_LTLIBRARIES = libconsumer.la
 noinst_HEADERS = consumer-metadata-cache.h consumer-timer.h \
                 consumer-testpoint.h
 
-libconsumer_la_SOURCES = consumer.c consumer.h consumer-metadata-cache.c \
-                         consumer-timer.c consumer-stream.c consumer-stream.h
+libconsumer_la_SOURCES = \
+       consumer.cpp \
+       consumer.h \
+       consumer-metadata-cache.cpp \
+       consumer-stream.cpp \
+       consumer-stream.h \
+       consumer-timer.cpp \
+       metadata-bucket.cpp \
+       metadata-bucket.h
 
 libconsumer_la_LIBADD = \
                $(top_builddir)/src/common/sessiond-comm/libsessiond-comm.la \
                $(top_builddir)/src/common/kernel-consumer/libkernel-consumer.la \
-               $(top_builddir)/src/common/hashtable/libhashtable.la \
-               $(top_builddir)/src/common/compat/libcompat.la \
                $(top_builddir)/src/common/relayd/librelayd.la
 
 if HAVE_LIBLTTNG_UST_CTL
This page took 0.023536 seconds and 4 git commands to generate.