Rename config.h to session-config.h
[lttng-tools.git] / src / common / config / Makefile.am
index 9e91b943dabfd41f415b1230762c6c4203741e94..6e33d5b600e01d69c50b2297051b729dc9278d53 100644 (file)
@@ -1,3 +1,26 @@
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src
+
 noinst_LTLIBRARIES = libconfig.la
 
-libconfig_la_SOURCES = ini.c ini.h
+libconfig_la_SOURCES = ini.c ini.h session-config.c session-config.h \
+               config-session-abi.h config-internal.h
+libconfig_la_CPPFLAGS = $(XML_CPPFLAGS) $(AM_CPPFLAGS)
+libconfig_la_LIBADD = $(XML_LIBS)
+
+xmldir = $(datadir)/xml/lttng
+dist_xml_DATA = session.xsd
+EXTRA_DIST = session.xsd
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+               cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+               rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.024381 seconds and 4 git commands to generate.