common: move bytecode utilities from filter to its own file
[lttng-tools.git] / src / common / Makefile.am
index bbddbe7ebffc03e8b41953056e0748280c2ddd3b..cfb935c5ad2b2dc6d43c088478f95fdbc8002f43 100644 (file)
@@ -2,7 +2,11 @@
 
 AUTOMAKE_OPTIONS = subdir-objects
 
-SUBDIRS = string-utils filter
+SUBDIRS = \
+       string-utils \
+       bytecode \
+       filter \
+       argpar
 
 # Make sure to always distribute all folders
 # since SUBDIRS is decided at configure time.
@@ -21,7 +25,10 @@ DIST_SUBDIRS = \
        consumer \
        string-utils \
        fd-tracker \
-       filter
+       bytecode \
+       filter \
+       argpar
+
 # Common library
 noinst_LTLIBRARIES = libcommon.la
 EXTRA_DIST = mi-lttng-4.0.xsd
@@ -93,6 +100,7 @@ libcommon_la_SOURCES += \
 endif
 
 libcommon_la_LIBADD = \
+       $(top_builddir)/src/common/bytecode/libbytecode.la \
        $(top_builddir)/src/common/config/libconfig.la \
        $(top_builddir)/src/common/compat/libcompat.la \
        $(top_builddir)/src/common/hashtable/libhashtable.la \
This page took 0.023414 seconds and 4 git commands to generate.