common: compile libconfig as C++
[lttng-tools.git] / src / common / Makefile.am
index ca0973403b7a0c07fc37e6d2e49112993618abe2..cb8ac7b10ab2190a98adca2bf62dd2e4a6885d61 100644 (file)
@@ -35,7 +35,7 @@ DIST_SUBDIRS = \
 
 # Common library
 noinst_LTLIBRARIES = libcommon.la
-EXTRA_DIST = mi-lttng-4.0.xsd
+EXTRA_DIST = mi-lttng-4.1.xsd
 
 libcommon_la_SOURCES = \
        actions/action.c \
@@ -67,7 +67,6 @@ libcommon_la_SOURCES = \
        evaluation.c \
        event.c \
        event-expr/event-expr.c \
-       event-expr-to-bytecode.c event-expr-to-bytecode.h \
        event-field-value.c \
        event-rule/event-rule.c \
        event-rule/kernel-kprobe.c \
@@ -176,7 +175,7 @@ noinst_HEADERS = \
        utils.h
 
 noinst_PROGRAMS = filter-grammar-test
-filter_grammar_test_SOURCES = filter-grammar-test.c
+filter_grammar_test_SOURCES = filter-grammar-test.cpp
 filter_grammar_test_LDADD = \
        libcommon.la
 
This page took 0.024496 seconds and 4 git commands to generate.