Clean-up: sessiond: make some accesses to conditions const
[lttng-tools.git] / src / common / Makefile.am
index cfb935c5ad2b2dc6d43c088478f95fdbc8002f43..caf588e4093e9017a8138a3883c934bed6bef57c 100644 (file)
@@ -45,7 +45,7 @@ libcommon_la_SOURCES = \
        common.h \
        conditions/buffer-usage.c \
        conditions/condition.c \
-       conditions/event-rule.c \
+       conditions/on-event.c \
        conditions/session-consumed-size.c \
        conditions/session-rotation.c \
        context.c context.h \
@@ -59,10 +59,12 @@ libcommon_la_SOURCES = \
        error.c error.h \
        evaluation.c \
        event.c \
+       event-expr-to-bytecode.c event-expr-to-bytecode.h \
+       event-field-value.c \
        event-rule/event-rule.c \
-       event-rule/kprobe.c \
+       event-rule/kernel-probe.c \
        event-rule/syscall.c \
-       event-rule/uprobe.c \
+       event-rule/userspace-probe.c \
        event-rule/tracepoint.c \
        filter.c filter.h \
        fd-handle.c fd-handle.h \
@@ -70,6 +72,7 @@ libcommon_la_SOURCES = \
        futex.c futex.h \
        kernel-probe.c \
        location.c \
+       log-level-rule.c \
        mi-lttng.c mi-lttng.h \
        notification.c \
        optional.h \
@@ -105,7 +108,8 @@ libcommon_la_LIBADD = \
        $(top_builddir)/src/common/compat/libcompat.la \
        $(top_builddir)/src/common/hashtable/libhashtable.la \
        $(top_builddir)/src/common/fd-tracker/libfd-tracker.la \
-       $(top_builddir)/src/common/filter/libfilter.la
+       $(top_builddir)/src/common/filter/libfilter.la \
+       $(top_builddir)/src/vendor/msgpack/libmsgpack.la
 
 if BUILD_LIB_COMPAT
 SUBDIRS += compat
This page took 0.023587 seconds and 4 git commands to generate.