Clean-up: sessiond: make some accesses to conditions const
[lttng-tools.git] / src / common / Makefile.am
index 8a74b728249afe4b5c22d2336a83eb8bc37906da..caf588e4093e9017a8138a3883c934bed6bef57c 100644 (file)
@@ -4,6 +4,7 @@ AUTOMAKE_OPTIONS = subdir-objects
 
 SUBDIRS = \
        string-utils \
+       bytecode \
        filter \
        argpar
 
@@ -24,6 +25,7 @@ DIST_SUBDIRS = \
        consumer \
        string-utils \
        fd-tracker \
+       bytecode \
        filter \
        argpar
 
@@ -43,7 +45,7 @@ libcommon_la_SOURCES = \
        common.h \
        conditions/buffer-usage.c \
        conditions/condition.c \
-       conditions/event-rule.c \
+       conditions/on-event.c \
        conditions/session-consumed-size.c \
        conditions/session-rotation.c \
        context.c context.h \
@@ -57,10 +59,12 @@ libcommon_la_SOURCES = \
        error.c error.h \
        evaluation.c \
        event.c \
+       event-expr-to-bytecode.c event-expr-to-bytecode.h \
+       event-field-value.c \
        event-rule/event-rule.c \
-       event-rule/kprobe.c \
+       event-rule/kernel-probe.c \
        event-rule/syscall.c \
-       event-rule/uprobe.c \
+       event-rule/userspace-probe.c \
        event-rule/tracepoint.c \
        filter.c filter.h \
        fd-handle.c fd-handle.h \
@@ -68,6 +72,7 @@ libcommon_la_SOURCES = \
        futex.c futex.h \
        kernel-probe.c \
        location.c \
+       log-level-rule.c \
        mi-lttng.c mi-lttng.h \
        notification.c \
        optional.h \
@@ -98,11 +103,13 @@ libcommon_la_SOURCES += \
 endif
 
 libcommon_la_LIBADD = \
+       $(top_builddir)/src/common/bytecode/libbytecode.la \
        $(top_builddir)/src/common/config/libconfig.la \
        $(top_builddir)/src/common/compat/libcompat.la \
        $(top_builddir)/src/common/hashtable/libhashtable.la \
        $(top_builddir)/src/common/fd-tracker/libfd-tracker.la \
-       $(top_builddir)/src/common/filter/libfilter.la
+       $(top_builddir)/src/common/filter/libfilter.la \
+       $(top_builddir)/src/vendor/msgpack/libmsgpack.la
 
 if BUILD_LIB_COMPAT
 SUBDIRS += compat
This page took 0.023934 seconds and 4 git commands to generate.