common: introduce lttng_event_expr_to_bytecode
[lttng-tools.git] / src / common / Makefile.am
index bbddbe7ebffc03e8b41953056e0748280c2ddd3b..c8707f48e814d3dd729fd74dd4dd5c5490b02257 100644 (file)
@@ -2,7 +2,11 @@
 
 AUTOMAKE_OPTIONS = subdir-objects
 
-SUBDIRS = string-utils filter
+SUBDIRS = \
+       string-utils \
+       bytecode \
+       filter \
+       argpar
 
 # Make sure to always distribute all folders
 # since SUBDIRS is decided at configure time.
@@ -21,7 +25,10 @@ DIST_SUBDIRS = \
        consumer \
        string-utils \
        fd-tracker \
-       filter
+       bytecode \
+       filter \
+       argpar
+
 # Common library
 noinst_LTLIBRARIES = libcommon.la
 EXTRA_DIST = mi-lttng-4.0.xsd
@@ -52,6 +59,7 @@ libcommon_la_SOURCES = \
        error.c error.h \
        evaluation.c \
        event.c \
+       event-expr-to-bytecode.c event-expr-to-bytecode.h \
        event-rule/event-rule.c \
        event-rule/kprobe.c \
        event-rule/syscall.c \
@@ -93,6 +101,7 @@ libcommon_la_SOURCES += \
 endif
 
 libcommon_la_LIBADD = \
+       $(top_builddir)/src/common/bytecode/libbytecode.la \
        $(top_builddir)/src/common/config/libconfig.la \
        $(top_builddir)/src/common/compat/libcompat.la \
        $(top_builddir)/src/common/hashtable/libhashtable.la \
This page took 0.023222 seconds and 4 git commands to generate.