common: introduce lttng_event_expr_to_bytecode
[lttng-tools.git] / src / common / Makefile.am
index 8a74b728249afe4b5c22d2336a83eb8bc37906da..c8707f48e814d3dd729fd74dd4dd5c5490b02257 100644 (file)
@@ -4,6 +4,7 @@ AUTOMAKE_OPTIONS = subdir-objects
 
 SUBDIRS = \
        string-utils \
+       bytecode \
        filter \
        argpar
 
@@ -24,6 +25,7 @@ DIST_SUBDIRS = \
        consumer \
        string-utils \
        fd-tracker \
+       bytecode \
        filter \
        argpar
 
@@ -57,6 +59,7 @@ libcommon_la_SOURCES = \
        error.c error.h \
        evaluation.c \
        event.c \
+       event-expr-to-bytecode.c event-expr-to-bytecode.h \
        event-rule/event-rule.c \
        event-rule/kprobe.c \
        event-rule/syscall.c \
@@ -98,6 +101,7 @@ libcommon_la_SOURCES += \
 endif
 
 libcommon_la_LIBADD = \
+       $(top_builddir)/src/common/bytecode/libbytecode.la \
        $(top_builddir)/src/common/config/libconfig.la \
        $(top_builddir)/src/common/compat/libcompat.la \
        $(top_builddir)/src/common/hashtable/libhashtable.la \
This page took 0.023915 seconds and 4 git commands to generate.