Merge branch 'master' of git://git.lttng.org/lttng-tools
[lttng-tools.git] / src / common / Makefile.am
index a8125bc404407c44451297c30ff60f3d370a6775..ba93810a8c3fe6af5bf8bd7c4188d037de4421ec 100644 (file)
@@ -4,11 +4,22 @@ SUBDIRS = hashtable kernel-ctl sessiond-comm kernel-consumer ust-consumer
 
 AM_CFLAGS = -fno-strict-aliasing
 
-noinst_HEADERS = lttng-share.h lttngerr.h lttng-kernel.h
+noinst_HEADERS = lttng-kernel.h defaults.h macros.h error.h
 
 noinst_LTLIBRARIES = libcommon.la
 
-libcommon_la_SOURCES = runas.c runas.h
+libcommon_la_SOURCES = runas.c runas.h common.h
+
+if COMPAT_EPOLL
+COMPAT=compat/compat-epoll.c
+else
+COMPAT=compat/compat-poll.c
+endif
+
+noinst_LTLIBRARIES += libcompat.la
+
+libcompat_la_SOURCES = compat/poll.h compat/fcntl.h compat/splice.h compat/endian.h \
+                       compat/socket.h compat/compat-fcntl.c $(COMPAT)
 
 # Consumer library
 noinst_LTLIBRARIES += libconsumer.la
@@ -18,7 +29,8 @@ libconsumer_la_SOURCES = consumer.c consumer.h
 libconsumer_la_LIBADD = \
                $(top_builddir)/src/common/sessiond-comm/libsessiond-comm.la \
                $(top_builddir)/src/common/kernel-consumer/libkernel-consumer.la \
-               $(top_builddir)/src/common/hashtable/libhashtable.la
+               $(top_builddir)/src/common/hashtable/libhashtable.la \
+               $(top_builddir)/src/common/libcompat.la
 
 if HAVE_LIBLTTNG_UST_CTL
 libconsumer_la_LIBADD += \
This page took 0.02279 seconds and 4 git commands to generate.