Fix: possible null dereference
[lttng-tools.git] / src / common / Makefile.am
index e7ceefe47cf8d5a1b9e0ad659103e507557cd44e..a50123989475fe1b4235032719ab60834599e185 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 AUTOMAKE_OPTIONS = subdir-objects
 
 SUBDIRS = string-utils
@@ -63,7 +65,8 @@ libcommon_la_SOURCES = \
        utils.c utils.h \
        uuid.c uuid.h \
        tracker.c \
-       waiter.c waiter.h
+       waiter.c waiter.h \
+       fs-handle.h fs-handle-internal.h fs-handle.c
 
 if HAVE_ELF_H
 libcommon_la_SOURCES += \
@@ -73,7 +76,8 @@ endif
 libcommon_la_LIBADD = \
        $(top_builddir)/src/common/config/libconfig.la \
        $(top_builddir)/src/common/compat/libcompat.la \
-       $(top_builddir)/src/common/hashtable/libhashtable.la
+       $(top_builddir)/src/common/hashtable/libhashtable.la \
+       $(top_builddir)/src/common/fd-tracker/libfd-tracker.la
 
 if BUILD_LIB_COMPAT
 SUBDIRS += compat
This page took 0.023111 seconds and 4 git commands to generate.