Fix: possible null dereference
[lttng-tools.git] / src / common / Makefile.am
index 95935b76e6283b2ae9a9cdf1195c60f757848a67..a50123989475fe1b4235032719ab60834599e185 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 AUTOMAKE_OPTIONS = subdir-objects
 
 SUBDIRS = string-utils
@@ -62,7 +64,9 @@ libcommon_la_SOURCES = \
        userspace-probe.c \
        utils.c utils.h \
        uuid.c uuid.h \
-       waiter.c waiter.h
+       tracker.c \
+       waiter.c waiter.h \
+       fs-handle.h fs-handle-internal.h fs-handle.c
 
 if HAVE_ELF_H
 libcommon_la_SOURCES += \
@@ -72,7 +76,8 @@ endif
 libcommon_la_LIBADD = \
        $(top_builddir)/src/common/config/libconfig.la \
        $(top_builddir)/src/common/compat/libcompat.la \
-       $(top_builddir)/src/common/hashtable/libhashtable.la
+       $(top_builddir)/src/common/hashtable/libhashtable.la \
+       $(top_builddir)/src/common/fd-tracker/libfd-tracker.la
 
 if BUILD_LIB_COMPAT
 SUBDIRS += compat
This page took 0.024114 seconds and 4 git commands to generate.