Fix: syscall event rule: emission sites not compared in is_equal
[lttng-tools.git] / src / common / Makefile.am
index 0a5e5a8f11dea0574955942dd3131e4812cbe478..34fd83452802f5b8caa21a347ce4264e693f1e88 100644 (file)
@@ -57,11 +57,13 @@ libcommon_lgpl_la_SOURCES = \
        actions/rate-policy.cpp \
        buffer-view.hpp buffer-view.cpp \
        channel.cpp \
+       compiler.hpp \
        conditions/buffer-usage.cpp \
        conditions/condition.cpp \
        conditions/event-rule-matches.cpp \
        conditions/session-consumed-size.cpp \
        conditions/session-rotation.cpp \
+       container-wrapper.hpp \
        credentials.cpp credentials.hpp \
        defaults.cpp \
        domain.cpp \
@@ -84,18 +86,28 @@ libcommon_lgpl_la_SOURCES = \
        event-rule/jul-logging.cpp \
        event-rule/python-logging.cpp \
        exception.cpp exception.hpp \
-       fd-handle.cpp fd-handle.hpp\
+       file-descriptor.hpp file-descriptor.cpp \
+       fd-handle.cpp fd-handle.hpp \
        format.hpp \
+       io-hint.cpp \
+       io-hint.hpp \
        kernel-probe.cpp \
        location.cpp \
+       lockfile.cpp lockfile.hpp \
+       locked-reference.hpp \
+       logging-utils.hpp logging-utils.cpp \
        log-level-rule.cpp \
+       make-unique.hpp \
        make-unique-wrapper.hpp \
        mi-lttng.cpp mi-lttng.hpp \
        notification.cpp \
        payload.cpp payload.hpp \
        payload-view.cpp payload-view.hpp \
+       pthread-lock.hpp \
+       random.cpp random.hpp \
        readwrite.cpp readwrite.hpp \
        runas.cpp runas.hpp \
+       scope-exit.hpp \
        session-descriptor.cpp \
        snapshot.cpp snapshot.hpp \
        spawn-viewer.cpp spawn-viewer.hpp \
@@ -106,8 +118,13 @@ libcommon_lgpl_la_SOURCES = \
        unix.cpp unix.hpp \
        uri.cpp uri.hpp \
        userspace-probe.cpp \
+       urcu.hpp \
        utils.cpp utils.hpp
 
+if IS_LINUX
+libcommon_lgpl_la_SOURCES += eventfd.cpp eventfd.hpp
+endif
+
 if HAVE_ELF_H
 libcommon_lgpl_la_SOURCES += \
        lttng-elf.cpp lttng-elf.hpp
@@ -159,13 +176,11 @@ libcommon_gpl_la_LIBADD = \
 # libcompat
 noinst_LTLIBRARIES += libcompat.la
 libcompat_la_SOURCES = \
-        compat/compat-fcntl.cpp \
         compat/directory-handle.cpp \
         compat/directory-handle.hpp \
         compat/dirent.hpp \
         compat/endian.hpp \
         compat/errno.hpp \
-        compat/fcntl.hpp \
         compat/getenv.hpp \
         compat/mman.hpp \
         compat/netdb.hpp \
This page took 0.024256 seconds and 4 git commands to generate.