CLI: add-trigger: add --capture option to `on-event` condition
[lttng-tools.git] / src / common / Makefile.am
index 9df1790fba9841f12052a9b8634b3d0d142dcc6b..8a74b728249afe4b5c22d2336a83eb8bc37906da 100644 (file)
@@ -2,7 +2,10 @@
 
 AUTOMAKE_OPTIONS = subdir-objects
 
-SUBDIRS = string-utils filter
+SUBDIRS = \
+       string-utils \
+       filter \
+       argpar
 
 # Make sure to always distribute all folders
 # since SUBDIRS is decided at configure time.
@@ -21,7 +24,9 @@ DIST_SUBDIRS = \
        consumer \
        string-utils \
        fd-tracker \
-       filter
+       filter \
+       argpar
+
 # Common library
 noinst_LTLIBRARIES = libcommon.la
 EXTRA_DIST = mi-lttng-4.0.xsd
@@ -38,6 +43,7 @@ libcommon_la_SOURCES = \
        common.h \
        conditions/buffer-usage.c \
        conditions/condition.c \
+       conditions/event-rule.c \
        conditions/session-consumed-size.c \
        conditions/session-rotation.c \
        context.c context.h \
This page took 0.022537 seconds and 4 git commands to generate.