Add named pipe support to the pipe wrapper
[lttng-tools.git] / src / common / Makefile.am
index 8633730a92b102baee5ee59f8b5b226e241750d7..83354d070ba6b755c663724731d308a5b7e93cea 100644 (file)
@@ -61,7 +61,7 @@ AM_CFLAGS = -fno-strict-aliasing
 
 noinst_HEADERS = lttng-kernel.h defaults.h macros.h error.h futex.h \
                                 uri.h utils.h lttng-kernel-old.h \
-                                align.h bitfield.h bug.h
+                                align.h bitfield.h bug.h time.h
 
 # Common library
 noinst_LTLIBRARIES = libcommon.la
@@ -73,12 +73,17 @@ libcommon_la_SOURCES = error.h error.c utils.c utils.h runas.c runas.h \
                        mi-lttng.h mi-lttng.c \
                        daemonize.c daemonize.h \
                        unix.c unix.h \
-                       filter.c filter.h context.c context.h
+                       dynamic-buffer.h dynamic-buffer.c \
+                       buffer-view.h buffer-view.c
 
 libcommon_la_LIBADD = \
-               -luuid \
-               -lrt \
                $(top_builddir)/src/common/config/libconfig.la
+if LTTNG_BUILD_WITH_LIBUUID
+libcommon_la_LIBADD += -luuid
+endif
+if LTTNG_BUILD_WITH_LIBC_UUID
+libcommon_la_LIBADD += -lc
+endif
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.024613 seconds and 4 git commands to generate.