Add named pipe support to the pipe wrapper
[lttng-tools.git] / src / common / Makefile.am
index 37c451a45e1f5734aedba1436a5f66c8297f3d51..83354d070ba6b755c663724731d308a5b7e93cea 100644 (file)
@@ -61,7 +61,7 @@ AM_CFLAGS = -fno-strict-aliasing
 
 noinst_HEADERS = lttng-kernel.h defaults.h macros.h error.h futex.h \
                                 uri.h utils.h lttng-kernel-old.h \
-                                align.h bitfield.h bug.h
+                                align.h bitfield.h bug.h time.h
 
 # Common library
 noinst_LTLIBRARIES = libcommon.la
@@ -73,10 +73,10 @@ libcommon_la_SOURCES = error.h error.c utils.c utils.h runas.c runas.h \
                        mi-lttng.h mi-lttng.c \
                        daemonize.c daemonize.h \
                        unix.c unix.h \
-                       filter.c filter.h context.c context.h
+                       dynamic-buffer.h dynamic-buffer.c \
+                       buffer-view.h buffer-view.c
 
 libcommon_la_LIBADD = \
-               -lrt \
                $(top_builddir)/src/common/config/libconfig.la
 if LTTNG_BUILD_WITH_LIBUUID
 libcommon_la_LIBADD += -luuid
This page took 0.023908 seconds and 4 git commands to generate.