Fix: syscall event rule: emission sites not compared in is_equal
[lttng-tools.git] / src / common / Makefile.am
index e04b38347d47fb60a6ab8e7bb0563bdd07c55099..34fd83452802f5b8caa21a347ce4264e693f1e88 100644 (file)
@@ -63,6 +63,7 @@ libcommon_lgpl_la_SOURCES = \
        conditions/event-rule-matches.cpp \
        conditions/session-consumed-size.cpp \
        conditions/session-rotation.cpp \
+       container-wrapper.hpp \
        credentials.cpp credentials.hpp \
        defaults.cpp \
        domain.cpp \
@@ -73,7 +74,6 @@ libcommon_lgpl_la_SOURCES = \
        error-query.cpp \
        evaluation.cpp \
        event.cpp \
-       eventfd.hpp eventfd.cpp \
        event-expr/event-expr.cpp \
        event-field-value.cpp \
        event-rule/event-rule.cpp \
@@ -87,12 +87,13 @@ libcommon_lgpl_la_SOURCES = \
        event-rule/python-logging.cpp \
        exception.cpp exception.hpp \
        file-descriptor.hpp file-descriptor.cpp \
-       fd-handle.cpp fd-handle.hpp\
+       fd-handle.cpp fd-handle.hpp \
        format.hpp \
        io-hint.cpp \
        io-hint.hpp \
        kernel-probe.cpp \
        location.cpp \
+       lockfile.cpp lockfile.hpp \
        locked-reference.hpp \
        logging-utils.hpp logging-utils.cpp \
        log-level-rule.cpp \
@@ -120,6 +121,10 @@ libcommon_lgpl_la_SOURCES = \
        urcu.hpp \
        utils.cpp utils.hpp
 
+if IS_LINUX
+libcommon_lgpl_la_SOURCES += eventfd.cpp eventfd.hpp
+endif
+
 if HAVE_ELF_H
 libcommon_lgpl_la_SOURCES += \
        lttng-elf.cpp lttng-elf.hpp
This page took 0.023577 seconds and 4 git commands to generate.