Build fix: retrieve unix socket peer PID on non-unix platforms
[lttng-tools.git] / src / common / Makefile.am
index b90b8854c64f6a9cf80f488e9943b7b336d875d1..5d1904d9c084ecc4fb7359b5eb9c787d150e15c6 100644 (file)
@@ -3,10 +3,14 @@
 AUTOMAKE_OPTIONS = subdir-objects
 
 SUBDIRS = \
-       string-utils \
+       argpar \
        bytecode \
+       compat \
+       config \
+       fd-tracker \
+       string-utils \
        filter \
-       argpar
+       hashtable
 
 # Make sure to always distribute all folders
 # since SUBDIRS is decided at configure time.
@@ -31,12 +35,13 @@ DIST_SUBDIRS = \
 
 # Common library
 noinst_LTLIBRARIES = libcommon.la
-EXTRA_DIST = mi-lttng-4.0.xsd
+EXTRA_DIST = mi-lttng-4.1.xsd
 
 libcommon_la_SOURCES = \
        actions/action.c \
-       actions/group.c \
+       actions/list.c \
        actions/notify.c \
+       actions/path.c \
        actions/rotate-session.c \
        actions/snapshot-session.c \
        actions/start-session.c \
@@ -46,7 +51,7 @@ libcommon_la_SOURCES = \
        common.h \
        conditions/buffer-usage.c \
        conditions/condition.c \
-       conditions/on-event.c \
+       conditions/event-rule-matches.c \
        conditions/session-consumed-size.c \
        conditions/session-rotation.c \
        context.c context.h \
@@ -58,15 +63,20 @@ libcommon_la_SOURCES = \
        dynamic-buffer.c dynamic-buffer.h \
        endpoint.c \
        error.c error.h \
+       error-query.c \
        evaluation.c \
        event.c \
-       event-expr-to-bytecode.c event-expr-to-bytecode.h \
+       event-expr/event-expr.c \
        event-field-value.c \
        event-rule/event-rule.c \
-       event-rule/kernel-probe.c \
-       event-rule/syscall.c \
-       event-rule/userspace-probe.c \
-       event-rule/tracepoint.c \
+       event-rule/kernel-kprobe.c \
+       event-rule/kernel-syscall.c \
+       event-rule/kernel-uprobe.c \
+       event-rule/kernel-tracepoint.c \
+       event-rule/user-tracepoint.c \
+       event-rule/log4j-logging.c \
+       event-rule/jul-logging.c \
+       event-rule/python-logging.c \
        filter.c filter.h \
        fd-handle.c fd-handle.h \
        fs-handle.c fs-handle.h fs-handle-internal.h \
@@ -114,18 +124,10 @@ libcommon_la_LIBADD = \
        $(top_builddir)/src/common/filter/libfilter.la \
        $(top_builddir)/src/vendor/msgpack/libmsgpack.la
 
-if BUILD_LIB_COMPAT
-SUBDIRS += compat
-endif
-
 if BUILD_LIB_HEALTH
 SUBDIRS += health
 endif
 
-if BUILD_LIB_HASHTABLE
-SUBDIRS += hashtable
-endif
-
 if BUILD_LIB_KERNEL_CTL
 SUBDIRS += kernel-ctl
 endif
@@ -138,9 +140,6 @@ if BUILD_LIB_RELAYD
 SUBDIRS += relayd
 endif
 
-if BUILD_LIB_FD_TRACKER
-SUBDIRS += fd-tracker
-endif
 
 if BUILD_LIB_KERNEL_CONSUMER
 SUBDIRS += kernel-consumer
@@ -158,10 +157,6 @@ if BUILD_LIB_INDEX
 SUBDIRS += index
 endif
 
-if BUILD_LIB_CONFIG
-SUBDIRS += config
-endif
-
 if BUILD_LIB_CONSUMER
 SUBDIRS += consumer
 endif
@@ -179,6 +174,11 @@ noinst_HEADERS = \
        uri.h \
        utils.h
 
+noinst_PROGRAMS = filter-grammar-test
+filter_grammar_test_SOURCES = filter-grammar-test.c
+filter_grammar_test_LDADD = \
+       libcommon.la
+
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
                for script in $(EXTRA_DIST); do \
This page took 0.03033 seconds and 4 git commands to generate.