Import CStringView from the Babeltrace tree
[lttng-tools.git] / src / common / Makefile.am
index 23d33e983b19bb3288c9edd565e29c6d2c9a4e31..8170e6e5add57dc5c66e459b9612e2bbbb2a2c4a 100644 (file)
@@ -57,11 +57,13 @@ libcommon_lgpl_la_SOURCES = \
        actions/rate-policy.cpp \
        buffer-view.hpp buffer-view.cpp \
        channel.cpp \
        actions/rate-policy.cpp \
        buffer-view.hpp buffer-view.cpp \
        channel.cpp \
+       compiler.hpp \
        conditions/buffer-usage.cpp \
        conditions/condition.cpp \
        conditions/event-rule-matches.cpp \
        conditions/session-consumed-size.cpp \
        conditions/session-rotation.cpp \
        conditions/buffer-usage.cpp \
        conditions/condition.cpp \
        conditions/event-rule-matches.cpp \
        conditions/session-consumed-size.cpp \
        conditions/session-rotation.cpp \
+       container-wrapper.hpp \
        credentials.cpp credentials.hpp \
        defaults.cpp \
        domain.cpp \
        credentials.cpp credentials.hpp \
        defaults.cpp \
        domain.cpp \
@@ -84,10 +86,16 @@ libcommon_lgpl_la_SOURCES = \
        event-rule/jul-logging.cpp \
        event-rule/python-logging.cpp \
        exception.cpp exception.hpp \
        event-rule/jul-logging.cpp \
        event-rule/python-logging.cpp \
        exception.cpp exception.hpp \
-       fd-handle.cpp fd-handle.hpp\
+       file-descriptor.hpp file-descriptor.cpp \
+       fd-handle.cpp fd-handle.hpp \
        format.hpp \
        format.hpp \
+       io-hint.cpp \
+       io-hint.hpp \
        kernel-probe.cpp \
        location.cpp \
        kernel-probe.cpp \
        location.cpp \
+       lockfile.cpp lockfile.hpp \
+       locked-reference.hpp \
+       logging-utils.hpp logging-utils.cpp \
        log-level-rule.cpp \
        make-unique.hpp \
        make-unique-wrapper.hpp \
        log-level-rule.cpp \
        make-unique.hpp \
        make-unique-wrapper.hpp \
@@ -96,8 +104,10 @@ libcommon_lgpl_la_SOURCES = \
        payload.cpp payload.hpp \
        payload-view.cpp payload-view.hpp \
        pthread-lock.hpp \
        payload.cpp payload.hpp \
        payload-view.cpp payload-view.hpp \
        pthread-lock.hpp \
+       random.cpp random.hpp \
        readwrite.cpp readwrite.hpp \
        runas.cpp runas.hpp \
        readwrite.cpp readwrite.hpp \
        runas.cpp runas.hpp \
+       scope-exit.hpp \
        session-descriptor.cpp \
        snapshot.cpp snapshot.hpp \
        spawn-viewer.cpp spawn-viewer.hpp \
        session-descriptor.cpp \
        snapshot.cpp snapshot.hpp \
        spawn-viewer.cpp spawn-viewer.hpp \
@@ -105,12 +115,17 @@ libcommon_lgpl_la_SOURCES = \
        time.cpp \
        tracker.cpp tracker.hpp \
        trigger.cpp \
        time.cpp \
        tracker.cpp tracker.hpp \
        trigger.cpp \
+       type-traits.hpp \
        unix.cpp unix.hpp \
        uri.cpp uri.hpp \
        userspace-probe.cpp \
        urcu.hpp \
        utils.cpp utils.hpp
 
        unix.cpp unix.hpp \
        uri.cpp uri.hpp \
        userspace-probe.cpp \
        urcu.hpp \
        utils.cpp utils.hpp
 
+if IS_LINUX
+libcommon_lgpl_la_SOURCES += eventfd.cpp eventfd.hpp
+endif
+
 if HAVE_ELF_H
 libcommon_lgpl_la_SOURCES += \
        lttng-elf.cpp lttng-elf.hpp
 if HAVE_ELF_H
 libcommon_lgpl_la_SOURCES += \
        lttng-elf.cpp lttng-elf.hpp
@@ -162,13 +177,11 @@ libcommon_gpl_la_LIBADD = \
 # libcompat
 noinst_LTLIBRARIES += libcompat.la
 libcompat_la_SOURCES = \
 # libcompat
 noinst_LTLIBRARIES += libcompat.la
 libcompat_la_SOURCES = \
-        compat/compat-fcntl.cpp \
         compat/directory-handle.cpp \
         compat/directory-handle.hpp \
         compat/dirent.hpp \
         compat/endian.hpp \
         compat/errno.hpp \
         compat/directory-handle.cpp \
         compat/directory-handle.hpp \
         compat/dirent.hpp \
         compat/endian.hpp \
         compat/errno.hpp \
-        compat/fcntl.hpp \
         compat/getenv.hpp \
         compat/mman.hpp \
         compat/netdb.hpp \
         compat/getenv.hpp \
         compat/mman.hpp \
         compat/netdb.hpp \
@@ -420,6 +433,7 @@ endif
 # libstring-utils
 noinst_LTLIBRARIES += libstring-utils.la
 libstring_utils_la_SOURCES = \
 # libstring-utils
 noinst_LTLIBRARIES += libstring-utils.la
 libstring_utils_la_SOURCES = \
+       string-utils/c-string-view.hpp \
        string-utils/format.hpp \
        string-utils/string-utils.cpp \
        string-utils/string-utils.hpp
        string-utils/format.hpp \
        string-utils/string-utils.cpp \
        string-utils/string-utils.hpp
This page took 0.032403 seconds and 4 git commands to generate.