Move on-event*.* to event-rule-matches*.*
[lttng-tools.git] / src / common / Makefile.am
index 8a74b728249afe4b5c22d2336a83eb8bc37906da..4ea732e014ea672d1cadca4b59312a9017e3c35e 100644 (file)
@@ -4,6 +4,7 @@ AUTOMAKE_OPTIONS = subdir-objects
 
 SUBDIRS = \
        string-utils \
+       bytecode \
        filter \
        argpar
 
@@ -24,6 +25,7 @@ DIST_SUBDIRS = \
        consumer \
        string-utils \
        fd-tracker \
+       bytecode \
        filter \
        argpar
 
@@ -39,11 +41,12 @@ libcommon_la_SOURCES = \
        actions/snapshot-session.c \
        actions/start-session.c \
        actions/stop-session.c \
+       actions/rate-policy.c \
        buffer-view.h buffer-view.c \
        common.h \
        conditions/buffer-usage.c \
        conditions/condition.c \
-       conditions/event-rule.c \
+       conditions/event-rule-matches.c \
        conditions/session-consumed-size.c \
        conditions/session-rotation.c \
        context.c context.h \
@@ -55,19 +58,24 @@ libcommon_la_SOURCES = \
        dynamic-buffer.c dynamic-buffer.h \
        endpoint.c \
        error.c error.h \
+       error-query.c \
        evaluation.c \
        event.c \
+       event-expr-to-bytecode.c event-expr-to-bytecode.h \
+       event-field-value.c \
        event-rule/event-rule.c \
-       event-rule/kprobe.c \
+       event-rule/kernel-probe.c \
        event-rule/syscall.c \
-       event-rule/uprobe.c \
+       event-rule/userspace-probe.c \
        event-rule/tracepoint.c \
        filter.c filter.h \
        fd-handle.c fd-handle.h \
        fs-handle.c fs-handle.h fs-handle-internal.h \
        futex.c futex.h \
        kernel-probe.c \
+       index-allocator.c index-allocator.h \
        location.c \
+       log-level-rule.c \
        mi-lttng.c mi-lttng.h \
        notification.c \
        optional.h \
@@ -76,6 +84,7 @@ libcommon_la_SOURCES = \
        pipe.c pipe.h \
        readwrite.c readwrite.h \
        runas.c runas.h \
+       shm.c shm.h \
        session-descriptor.c \
        snapshot.c snapshot.h \
        spawn-viewer.c spawn-viewer.h \
@@ -98,11 +107,13 @@ libcommon_la_SOURCES += \
 endif
 
 libcommon_la_LIBADD = \
+       $(top_builddir)/src/common/bytecode/libbytecode.la \
        $(top_builddir)/src/common/config/libconfig.la \
        $(top_builddir)/src/common/compat/libcompat.la \
        $(top_builddir)/src/common/hashtable/libhashtable.la \
        $(top_builddir)/src/common/fd-tracker/libfd-tracker.la \
-       $(top_builddir)/src/common/filter/libfilter.la
+       $(top_builddir)/src/common/filter/libfilter.la \
+       $(top_builddir)/src/vendor/msgpack/libmsgpack.la
 
 if BUILD_LIB_COMPAT
 SUBDIRS += compat
This page took 0.024738 seconds and 4 git commands to generate.