Add daemonize() to libcommon
[lttng-tools.git] / src / common / Makefile.am
index f2ea40a23c55541d6c27e4f795e4514572a03810..3ba5fed5149ab91ff8536e7566858919b93dd34e 100644 (file)
@@ -1,7 +1,7 @@
 AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src
 
-SUBDIRS = compat hashtable kernel-ctl sessiond-comm relayd \
-                 kernel-consumer ust-consumer testpoint
+SUBDIRS = compat health hashtable kernel-ctl sessiond-comm relayd \
+                 kernel-consumer ust-consumer testpoint index config
 
 AM_CFLAGS = -fno-strict-aliasing
 
@@ -13,14 +13,16 @@ noinst_HEADERS = lttng-kernel.h defaults.h macros.h error.h futex.h \
 noinst_LTLIBRARIES = libcommon.la
 
 libcommon_la_SOURCES = error.h error.c utils.c utils.h runas.c runas.h \
-                       common.h futex.c futex.h uri.c uri.h defaults.c
+                       common.h futex.c futex.h uri.c uri.h defaults.c \
+                       pipe.c pipe.h readwrite.c readwrite.h \
+                       daemonize.c daemonize.h
 libcommon_la_LIBADD = -luuid
 
 # Consumer library
 noinst_LTLIBRARIES += libconsumer.la
 
 libconsumer_la_SOURCES = consumer.c consumer.h consumer-metadata-cache.c \
-                         consumer-timer.c
+                         consumer-timer.c consumer-stream.c consumer-stream.h
 
 libconsumer_la_LIBADD = \
                $(top_builddir)/src/common/sessiond-comm/libsessiond-comm.la \
This page took 0.024081 seconds and 4 git commands to generate.