Revert FreeBSD compatibility layer
[lttng-tools.git] / src / common / Makefile.am
index a8125bc404407c44451297c30ff60f3d370a6775..37f9acb9ab144b9a7ce711b4062d62a82bc78a4a 100644 (file)
@@ -4,11 +4,11 @@ SUBDIRS = hashtable kernel-ctl sessiond-comm kernel-consumer ust-consumer
 
 AM_CFLAGS = -fno-strict-aliasing
 
-noinst_HEADERS = lttng-share.h lttngerr.h lttng-kernel.h
+noinst_HEADERS = lttng-kernel.h defaults.h macros.h error.h
 
 noinst_LTLIBRARIES = libcommon.la
 
-libcommon_la_SOURCES = runas.c runas.h
+libcommon_la_SOURCES = runas.c runas.h common.h
 
 # Consumer library
 noinst_LTLIBRARIES += libconsumer.la
@@ -24,3 +24,13 @@ if HAVE_LIBLTTNG_UST_CTL
 libconsumer_la_LIBADD += \
                $(top_builddir)/src/common/ust-consumer/libust-consumer.la
 endif
+
+if COMPAT_EPOLL
+COMPAT=compat/compat-epoll.c
+else
+COMPAT=compat/compat-poll.c
+endif
+
+noinst_LTLIBRARIES += libcompat.la
+
+libcompat_la_SOURCES = compat/poll.h $(COMPAT)
This page took 0.023713 seconds and 4 git commands to generate.