Fix: futex can be free'd while used by waker thread
[lttng-tools.git] / src / common / Makefile.am
index 83354d070ba6b755c663724731d308a5b7e93cea..2cf497262fff100db47e2ca35d66add1ddbe955e 100644 (file)
@@ -2,12 +2,13 @@ AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src
 
 AUTOMAKE_OPTIONS = subdir-objects
 
-SUBDIRS =
+SUBDIRS = string-utils
 
 # Make sure to always distribute all folders
 # since SUBDIRS is decided at configure time.
 DIST_SUBDIRS = compat health hashtable kernel-ctl sessiond-comm relayd \
-         kernel-consumer ust-consumer testpoint index config consumer
+         kernel-consumer ust-consumer testpoint index config consumer \
+         string-utils
 
 if BUILD_LIB_COMPAT
 SUBDIRS += compat
@@ -73,6 +74,9 @@ libcommon_la_SOURCES = error.h error.c utils.c utils.h runas.c runas.h \
                        mi-lttng.h mi-lttng.c \
                        daemonize.c daemonize.h \
                        unix.c unix.h \
+                       filter.c filter.h context.c context.h \
+                       action.c notify.c condition.c buffer-usage.c \
+                       evaluation.c notification.c trigger.c endpoint.c \
                        dynamic-buffer.h dynamic-buffer.c \
                        buffer-view.h buffer-view.c
 
This page took 0.02332 seconds and 4 git commands to generate.