Fix: cleanup relayd on any I/O error in read subbuffer mmap
[lttng-tools.git] / src / common / Makefile.am
index 0c02d533c021105cd73c6d1e105f77b251955fba..1a764aec197f5133b71646eec502f16c26126c66 100644 (file)
@@ -1,20 +1,22 @@
 AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src
 
 SUBDIRS = compat health hashtable kernel-ctl sessiond-comm relayd \
-                 kernel-consumer ust-consumer testpoint index
+                 kernel-consumer ust-consumer testpoint index config
 
 AM_CFLAGS = -fno-strict-aliasing
 
 noinst_HEADERS = lttng-kernel.h defaults.h macros.h error.h futex.h \
                                 uri.h utils.h lttng-kernel-old.h \
-                                consumer-metadata-cache.h consumer-timer.h
+                                consumer-metadata-cache.h consumer-timer.h \
+                                consumer-testpoint.h
 
 # Common library
 noinst_LTLIBRARIES = libcommon.la
 
 libcommon_la_SOURCES = error.h error.c utils.c utils.h runas.c runas.h \
                        common.h futex.c futex.h uri.c uri.h defaults.c \
-                       pipe.c pipe.h
+                       pipe.c pipe.h readwrite.c readwrite.h \
+                       daemonize.c daemonize.h
 libcommon_la_LIBADD = -luuid
 
 # Consumer library
This page took 0.024182 seconds and 4 git commands to generate.