Fix: kernel adds creds on recv with SO_PASSCRED unix socket option
[lttng-tools.git] / src / common / Makefile.am
index 0b804350648b0c8c2684a5c8fef2ea75065d61a8..171748f433aacc32cc3f79254e1cb1ea4e1957ec 100644 (file)
@@ -7,6 +7,37 @@ SUBDIRS = string-utils
 DIST_SUBDIRS = compat health hashtable kernel-ctl sessiond-comm relayd \
          kernel-consumer ust-consumer testpoint index config consumer \
          string-utils
+#
+# Common library
+noinst_LTLIBRARIES = libcommon.la
+EXTRA_DIST = mi-lttng-3.0.xsd
+
+libcommon_la_SOURCES = error.h error.c utils.c utils.h runas.h runas.c \
+                       common.h futex.c futex.h uri.c uri.h defaults.c \
+                       pipe.c pipe.h readwrite.c readwrite.h \
+                       mi-lttng.h mi-lttng.c \
+                       daemonize.c daemonize.h \
+                       unix.h \
+                       filter.c filter.h context.c context.h \
+                       action.c notify.c condition.c buffer-usage.c \
+                       session-consumed-size.c \
+                       session-rotation.c \
+                       evaluation.c notification.c trigger.c endpoint.c \
+                       dynamic-buffer.h dynamic-buffer.c \
+                       buffer-view.h buffer-view.c \
+                       location.c \
+                       waiter.h waiter.c \
+                       userspace-probe.c
+
+libcommon_la_LIBADD = \
+               $(top_builddir)/src/common/config/libconfig.la \
+               $(UUID_LIBS)
+
+if BUILD_LIB_UNIX
+libcommon_la_SOURCES += unix.c
+else
+libcommon_la_SOURCES += unix-stub.c
+endif
 
 if BUILD_LIB_COMPAT
 SUBDIRS += compat
@@ -60,31 +91,6 @@ noinst_HEADERS = lttng-kernel.h defaults.h macros.h error.h futex.h \
                                 uri.h utils.h lttng-kernel-old.h \
                                 align.h bitfield.h bug.h time.h
 
-# Common library
-noinst_LTLIBRARIES = libcommon.la
-EXTRA_DIST = mi-lttng-3.0.xsd
-
-libcommon_la_SOURCES = error.h error.c utils.c utils.h runas.c runas.h \
-                       common.h futex.c futex.h uri.c uri.h defaults.c \
-                       pipe.c pipe.h readwrite.c readwrite.h \
-                       mi-lttng.h mi-lttng.c \
-                       daemonize.c daemonize.h \
-                       unix.c unix.h \
-                       filter.c filter.h context.c context.h \
-                       action.c notify.c condition.c buffer-usage.c \
-                       session-consumed-size.c \
-                       session-rotation.c \
-                       evaluation.c notification.c trigger.c endpoint.c \
-                       dynamic-buffer.h dynamic-buffer.c \
-                       buffer-view.h buffer-view.c \
-                       location.c \
-                       waiter.h waiter.c \
-                       userspace-probe.c
-
-libcommon_la_LIBADD = \
-               $(top_builddir)/src/common/config/libconfig.la \
-               $(UUID_LIBS)
-
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
                for script in $(EXTRA_DIST); do \
This page took 0.023917 seconds and 4 git commands to generate.