Fix: syscall event rule: emission sites not compared in is_equal
[lttng-tools.git] / src / bin / lttng / Makefile.am
index 62ae059374063e0aa010b9bb921da7d8ace07fb7..e3718374637deda24acccd4bc1ccc5c0cd7443ae 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 AM_CPPFLAGS += -DINSTALL_BIN_PATH=\""$(bindir)"\"
 
 if EMBED_HELP
@@ -8,30 +10,41 @@ AUTOMAKE_OPTIONS = subdir-objects
 
 bin_PROGRAMS = lttng
 
-lttng_SOURCES = command.h conf.c conf.h commands/start.c \
-                               commands/list.c commands/create.c commands/destroy.c \
-                               commands/stop.c commands/enable_events.c \
-                               commands/disable_events.c commands/enable_channels.c \
-                               commands/disable_channels.c commands/add_context.c \
-                               commands/set_session.c commands/version.c \
-                               commands/view.c \
-                               commands/snapshot.c \
-                               commands/save.c \
-                               commands/load.c \
-                               commands/track-untrack.c \
-                               commands/status.c \
-                               commands/metadata.c \
-                               commands/regenerate.c \
-                               commands/help.c \
-                               commands/rotate.c \
-                               commands/enable_rotation.c \
-                               commands/disable_rotation.c \
-                               utils.c utils.h lttng.c
+lttng_SOURCES = command.hpp conf.cpp conf.hpp commands/start.cpp \
+                               commands/list.cpp commands/create.cpp commands/destroy.cpp \
+                               commands/stop.cpp commands/enable_events.cpp \
+                               commands/disable_events.cpp commands/enable_channels.cpp \
+                               commands/disable_channels.cpp commands/add_context.cpp \
+                               commands/set_session.cpp commands/version.cpp \
+                               commands/view.cpp \
+                               commands/snapshot.cpp \
+                               commands/save.cpp \
+                               commands/load.cpp \
+                               commands/track-untrack.cpp \
+                               commands/status.cpp \
+                               commands/metadata.cpp \
+                               commands/regenerate.cpp \
+                               commands/help.cpp \
+                               commands/rotate.cpp \
+                               commands/enable_rotation.cpp \
+                               commands/disable_rotation.cpp \
+                               commands/clear.cpp \
+                               loglevel.cpp loglevel.hpp \
+                               commands/add_trigger.cpp \
+                               commands/list_triggers.cpp \
+                               commands/remove_trigger.cpp \
+                               utils.cpp utils.hpp lttng.cpp \
+                               uprobe.cpp uprobe.hpp \
+                               exception.hpp exception.cpp
 
-lttng_CFLAGS = $(AM_CFLAGS) $(POPT_CFLAGS)
+lttng_CXXFLAGS = $(AM_CXXFLAGS) $(POPT_CFLAGS)
 
 lttng_LDADD = $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la \
-                       $(top_builddir)/src/common/libcommon.la \
-                       $(top_builddir)/src/common/config/libconfig.la \
-                       $(top_builddir)/src/common/string-utils/libstring-utils.la \
+                       $(top_builddir)/src/common/libcommon-lgpl.la \
+                       $(top_builddir)/src/common/libpath.la \
+                       $(top_builddir)/src/common/libconfig.la \
+                       $(top_builddir)/src/common/libstring-utils.la \
+                       $(top_builddir)/src/common/libfilter.la \
+                       $(top_builddir)/src/common/libargpar-utils.la \
+                       $(top_builddir)/src/common/libargpar.la \
                        $(POPT_LIBS)
This page took 0.023887 seconds and 4 git commands to generate.