Rename *emission_site_type to *emission_site
[lttng-tools.git] / src / bin / lttng-sessiond / Makefile.am
index d8e3b715d7b7926b550b4c5f973ae5bc7c7080ff..d0033a01924b20dae84a7f90bec1eff9d1460080 100644 (file)
@@ -12,14 +12,14 @@ bin_PROGRAMS = lttng-sessiond
 lttng_sessiond_SOURCES = utils.c utils.h \
                        trace-kernel.c trace-kernel.h \
                        kernel.c kernel.h \
-                       ust-app.h trace-ust.h notify-apps.h \
+                       ust-app.h ust-sigbus.h trace-ust.h notify-apps.h \
                        lttng-ust-ctl.h lttng-ust-abi.h lttng-ust-error.h \
                        ust-ctl-internal.h ust-abi-internal.h ust-error-internal.h \
                        ust-registry.h \
+                       condition-internal.c condition-internal.h \
                        context.c context.h \
                        channel.c channel.h \
                        event.c event.h \
-                       shm.c shm.h \
                        consumer.c consumer.h \
                        session.c session.h \
                        modprobe.c modprobe.h kern-modules.h \
@@ -55,13 +55,18 @@ lttng_sessiond_SOURCES = utils.c utils.h \
                        manage-consumer.c manage-consumer.h \
                        clear.c clear.h \
                        tracker.c tracker.h \
-                       action-executor.c action-executor.h
+                       event-notifier-error-accounting.c event-notifier-error-accounting.h \
+                       action-executor.c action-executor.h\
+                       trigger-error-query.c
+
+lttng_sessiond_LDFLAGS = -rdynamic
 
 if HAVE_LIBLTTNG_UST_CTL
 lttng_sessiond_SOURCES += trace-ust.c ust-registry.c ust-app.c \
                        ust-consumer.c ust-consumer.h notify-apps.c \
                        ust-metadata.c ust-clock.h agent-thread.c agent-thread.h \
-                       ust-field-utils.h ust-field-utils.c
+                       ust-field-utils.h ust-field-utils.c \
+                       ust-sigbus.c
 endif
 
 # Add main.c at the end for compile order
This page took 0.02347 seconds and 4 git commands to generate.