Fix: Handle SIGBUS in sessiond and consumerd
[lttng-tools.git] / src / bin / lttng-sessiond / Makefile.am
index 07aaa821ca19a9c4f83613ebca7dcb4505c14aa6..d0033a01924b20dae84a7f90bec1eff9d1460080 100644 (file)
@@ -12,7 +12,7 @@ bin_PROGRAMS = lttng-sessiond
 lttng_sessiond_SOURCES = utils.c utils.h \
                        trace-kernel.c trace-kernel.h \
                        kernel.c kernel.h \
-                       ust-app.h trace-ust.h notify-apps.h \
+                       ust-app.h ust-sigbus.h trace-ust.h notify-apps.h \
                        lttng-ust-ctl.h lttng-ust-abi.h lttng-ust-error.h \
                        ust-ctl-internal.h ust-abi-internal.h ust-error-internal.h \
                        ust-registry.h \
@@ -65,7 +65,8 @@ if HAVE_LIBLTTNG_UST_CTL
 lttng_sessiond_SOURCES += trace-ust.c ust-registry.c ust-app.c \
                        ust-consumer.c ust-consumer.h notify-apps.c \
                        ust-metadata.c ust-clock.h agent-thread.c agent-thread.h \
-                       ust-field-utils.h ust-field-utils.c
+                       ust-field-utils.h ust-field-utils.c \
+                       ust-sigbus.c
 endif
 
 # Add main.c at the end for compile order
This page took 0.023779 seconds and 4 git commands to generate.