Move compat to common and create an internal lib
[lttng-tools.git] / src / bin / lttng-sessiond / Makefile.am
index e824d4939105d135f2b9603c6aa255abde70827d..c431ade868b1717a4acbbd7963976fd3fd94d98e 100644 (file)
@@ -1,19 +1,11 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src \
-                         -DINSTALL_BIN_PATH=\""$(bindir)"\" \
+AM_CPPFLAGS = -DINSTALL_BIN_PATH=\""$(bindir)"\" \
                          -DINSTALL_LIB_PATH=\""$(libdir)"\"
 
 AM_CFLAGS = -fno-strict-aliasing
 
 bin_PROGRAMS = lttng-sessiond
 
-if COMPAT_EPOLL
-COMPAT=compat/compat-epoll.c
-else
-COMPAT=compat/compat-poll.c
-endif
-
 lttng_sessiond_SOURCES = utils.c utils.h \
-                       compat/poll.h $(COMPAT) \
                        trace-kernel.c trace-kernel.h \
                        kernel.c kernel.h \
                        ust-ctl.h ust-app.h trace-ust.h \
@@ -38,7 +30,8 @@ lttng_sessiond_LDADD = -lrt -lurcu-common -lurcu \
                $(top_builddir)/src/common/sessiond-comm/libsessiond-comm.la \
                $(top_builddir)/src/common/kernel-ctl/libkernel-ctl.la \
                $(top_builddir)/src/common/hashtable/libhashtable.la \
-               $(top_builddir)/src/common/libcommon.la
+               $(top_builddir)/src/common/libcommon.la \
+               $(top_builddir)/src/common/libcompat.la
 
 if HAVE_LIBLTTNG_UST_CTL
 lttng_sessiond_LDADD += -llttng-ust-ctl
This page took 0.024377 seconds and 4 git commands to generate.