Tests: spawn ht_cleanup thread in unit tests
[lttng-tools.git] / src / bin / lttng-sessiond / Makefile.am
index 60cf0feeb741c58546527d554069d2666934a738..29f48c9cc6670c0476134b0d17d69db320a7d903 100644 (file)
@@ -25,14 +25,17 @@ lttng_sessiond_SOURCES = utils.c utils.h \
                        health-sessiond.h \
                        cmd.c cmd.h \
                        buffer-registry.c buffer-registry.h \
-                       testpoint.h ht-cleanup.c \
+                       testpoint.h ht-cleanup.c ht-cleanup.h \
                        snapshot.c snapshot.h \
-                       jul.c jul.h jul-thread.c jul-thread.h
+                       agent.c agent.h \
+                       save.h save.c \
+                       load-session-thread.h load-session-thread.c \
+                       syscall.h syscall.c
 
 if HAVE_LIBLTTNG_UST_CTL
 lttng_sessiond_SOURCES += trace-ust.c ust-registry.c ust-app.c \
                        ust-consumer.c ust-consumer.h ust-thread.c \
-                       ust-metadata.c ust-clock.h
+                       ust-metadata.c ust-clock.h agent-thread.c agent-thread.h
 endif
 
 # Add main.c at the end for compile order
@@ -48,7 +51,9 @@ lttng_sessiond_LDADD = -lrt -lurcu-common -lurcu \
                $(top_builddir)/src/common/compat/libcompat.la \
                $(top_builddir)/src/common/relayd/librelayd.la \
                $(top_builddir)/src/common/testpoint/libtestpoint.la \
-               $(top_builddir)/src/common/health/libhealth.la
+               $(top_builddir)/src/common/health/libhealth.la \
+               $(top_builddir)/src/common/config/libconfig.la
+
 
 if HAVE_LIBLTTNG_UST_CTL
 lttng_sessiond_LDADD += -llttng-ust-ctl
This page took 0.023225 seconds and 4 git commands to generate.